svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
abort(3c)
Standard C Library Functions abort(3C)
NAME
abort - terminate the process abnormally
SYNOPSIS
#include <stdlib.h>
void abort(void);
DESCRIPTION
The abort() function causes abnormal process termination to occur,
unless the signal SIGABRT is being caught and the signal handler does
not return. The abnormal termination processing includes at least the
effect of fclose(3C) on all open streams and message catalogue descrip‐
tors, and the default actions defined for SIGABRT. The SIGABRT signal
is sent to the calling process as if by means of the raise(3C) function
with the argument SIGABRT.
The status made available to wait(3C) or waitpid(3C) by abort will be
that of a process terminated by the SIGABRT signal. abort will override
blocking or ignoring the SIGABRT signal.
RETURN VALUES
The abort() function does not return.
ERRORS
No errors are defined.
USAGE
Catching the signal is intended to provide the application writer with
a portable means to abort processing, free from possible interference
from any implementation-provided library functions. If SIGABRT is nei‐
ther caught nor ignored, and the current directory is writable, a core
dump may be produced.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe _ StandardSee standards(7).
SEE ALSO
exit(2), getrlimit(2), kill(2), fclose(3C), raise(3C), signal(3C),
wait(3C), waitpid(3C), attributes(7), standards(7)
Oracle Solaris 11.4 16 Aug 2017 abort(3C)