svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
posix_memalign(3c)
Standard C Library Functions posix_memalign(3C)
NAME
posix_memalign - aligned memory allocation
SYNOPSIS
#include <stdlib.h>
int posix_memalign(void **memptr, size_t alignment, size_t size);
DESCRIPTION
The posix_memalign() function allocates size bytes aligned on a bound‐
ary specified by alignment, and returns a pointer to the allocated mem‐
ory in memptr. The value of alignment must be a power of two multiple
of sizeof(void *).
Upon successful completion, the value pointed to by memptr will be a
multiple of alignment.
If the size of the space requested is 0, the value returned in memptr
will be a null pointer.
The free(3C) function will deallocate memory that has previously been
allocated by posix_memalign().
RETURN VALUES
Upon successful completion, posix_memalign() returns zero. Otherwise,
an error number is returned to indicate the error.
ERRORS
The posix_memalign() function will fail if:
EINVAL The value of the alignment parameter is not a power of two
multiple of sizeof(void *).
ENOMEM There is insufficient memory available with the requested
alignment.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelMT-Safe _ Stan‐
dardSee standards(7).
SEE ALSO
aligned_alloc(3C), free(3C), malloc(3C), memalign(3C), spawn.h(3HEAD),
attributes(7), standards(7)
Oracle Solaris 11.4 21 Nov 2014 posix_memalign(3C)