svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
dlerror(3c)
Standard C Library Functions dlerror(3C)
NAME
dlerror - get diagnostic information
SYNOPSIS
#include <dlfcn.h>
char *dlerror(void);
DESCRIPTION
The dlerror() function returns a null-terminated character string that
describes the last error that occurred during dynamic linking process‐
ing. The returned string contains no trailing newline. If no dynamic
linking errors have occurred since the last invocation of dlerror(),
dlerror() returns NULL. Thus, invoking dlerror() a second time, immedi‐
ately following a prior invocation, results in NULL being returned.
USAGE
The dlerror() function is one of a family of functions that give the
user direct access to the dynamic linking facilities. These facilities
are available to dynamically-linked processes only. See the Oracle
Solaris 11.4 Linkers and Libraries Guide.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelUnsafe _ Stan‐
dardSee standards(7).
SEE ALSO
dlopen(3C), ld(1), dladdr(3C), dlclose(3C), dldump(3C), dlsym(3C),
attributes(7), standards(7)
Oracle Solaris 11.4 Linkers and Libraries Guide
NOTES
The messages returned by dlerror() can reside in a static buffer that
is overwritten on each call to dlerror(). Application code should not
write to this buffer. Programs wanting to preserve an error message
should make their own copies of that message.
Oracle Solaris 11.4 9 August 2017 dlerror(3C)