svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
_stack_grow(3c)
Standard C Library Functions _stack_grow(3C)
NAME
_stack_grow - express an intention to extend the stack
SYNOPSIS
#include <ucontext.h>
void *_stack_grow(void *addr);
DESCRIPTION
The _stack_grow() function indicates to the system that the stack is
about to be extended to the address specified by addr. If extending the
stack to this address would violate the stack boundaries as retrieved
by stack_getbounds(3C), a SIGSEGV is raised.
If the disposition of SIGSEGV is SIG_DFL, the process is terminated and
a core dump is generated. If the application has installed its own
SIGSEGV handler to run on the alternate signal stack, the signal infor‐
mation passed to the handler will be such that a call to stack_viola‐
tion(3C) with these parameters returns 1.
The addr argument is a biased stack pointer value. See the Solaris
64-bit Developer's Guide.
This function has no effect if the specified address, addr, is within
the bounds of the current stack.
RETURN VALUES
If the _stack_grow() function succeeds and does not detect a stack vio‐
lation, it returns addr.
ERRORS
No errors are defined.
USAGE
The _stack_grow() function does not actually adjust the stack pointer
register. The caller is responsible for manipulating the stack pointer
register once _stack_grow() returns.
The _stack_grow() function is typically invoked by code created by the
compilation environment prior to executing code that modifies the stack
pointer. It can also be used by hand-written assembly routines to allo‐
cate stack-based storage safely.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ MT-LevelAsync-Signal-
Safe
SEE ALSO
stack_getbounds(3C), stack_inbounds(3C), stack_violation(3C),
attributes(7)
Solaris 64-bit Developer's Guide
Oracle Solaris 11.4 18 Jul 2002 _stack_grow(3C)