svcadm(8)을 검색하려면 섹션에서 8 을 선택하고, 맨 페이지 이름에 svcadm을 입력하고 검색을 누른다.
munmap(2)
munmap(2) System Calls munmap(2)
NAME
munmap - unmap pages of memory
SYNOPSIS
#include <sys/mman.h>
int munmap(void *addr, size_t len);
DESCRIPTION
The munmap() function removes the mappings for pages in the range
[addr, addr + len), rounding the len argument up to the next multiple
of the page size as returned by sysconf(3C). If addr is not the address
of a mapping established by a prior call to mmap(2), the behavior is
undefined. After a successful call to munmap() and before any subse‐
quent mapping of the unmapped pages, further references to these pages
will result in the delivery of a SIGBUS or SIGSEGV signal to the
process.
The mmap(2) function often performs an implicit munmap().
RETURN VALUES
Upon successful completion, munmap() returns 0; otherwise, it returns
−1 and sets errno to indicate an error.
ERRORS
The munmap() function will fail if:
EINVAL The addr argument is not a multiple of the page size as
returned by sysconf(3C); addresses in the range [addr, addr +
len) are outside the valid range for the address space of a
process; or the len argument has a value less than or equal
to 0.
ATTRIBUTES
See attributes(7) for descriptions of the following attributes:
tab() box; cw(2.75i) |cw(2.75i) lw(2.75i) |lw(2.75i) ATTRIBUTE TYPEAT‐
TRIBUTE VALUE _ Interface StabilityCommitted _ StandardSee stan‐
dards(7).
SEE ALSO
mmap(2), sysconf(3C), attributes(7), standards(7)
Oracle Solaris 11.4 5 Jan 1998 munmap(2)